Netwoven Tech-talk

Index Propagation Issue in MOSS 2007 Search

Posted by
Date : April 14, 2015

Error in MOSS 2007 search, this error occurs when index sever and query server are different and more than one query server exists. It turned out that the index had been corrupted on that server while the index was propagating from the index server.

End User experience:

While Searching from Portal, you get the below errors “Your search cannot be completed because of a service error” or “The search request was unable to connect to the Search Service

Problem: 

When having two servers configured so that one acts as Search Indexing server (APP server) and the other acts as Search Query server (WFE), you get multiple errors in event log and the search does not work.

On the Indexing server, errors are: 

Error #1
Event Type: Error
Event Source: Office Server Search
Event Category: Search service
Event ID: 10038
Description:
Query machine <xyz> has been taken out of rotation due to this error: The object is not initialzed.   0x8004180b. It will be retried in 15 seconds. Component: 3a87986b-8ffe-41db-ae22-5e3fd1b9f4d9

Error #2
Event Type:Warning
Event Source: Office Server Search
Event Category: Search service
Event ID: 10039
Description:
Retry of query machine <xyz> has failed with error: The object is not initialzed.   0x8004180b.  It will be retried again in 60 seconds. Component: 3a87986b-8ffe-41db-ae22-5e3fd1b9f4d9

Error #3
Event Type: Error
Event Source: Office Server Search
Event Category: Content index server
Event ID: 4127
Description:
Content index on Portal_Content could not be initialized. Error The system cannot find the file specified.   0x80070002.Component: 3a87986b-8ffe-41db-ae22-5e3fd1b9f4d9

On Query Server the errors are:
Event Type: Error
Event Source: Office SharePoint Server
Event Category: Office Server Shared Services
Event ID: 6482
Description:
Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (8fd1e03c-96df-4b7a-bd33-8da3fa924f03).

Root cause of this symptom

This problem occurs mostly when your Office SharePoint Service Search is not working (or configured correctly) or index had been corrupted on that server due to machine rebooting or some other reasons.

Solution:

First make sure the permissions are set correctly. Moreover, see that the Farm Search Service Account is in Administrators group and in WSS_ADMIN_WPG group on the Indexing and Query servers. After that stop and start theOffice SharePoint Server Search service in Central Admin. Also need to check that search service account have write permission on shared index of query server.

1. Stop Office SharePoint Service on all servers (command line option StsAdm.exe -o osearch -action stop)

2. Stop and Start MOSS timer service on all servers (OWSTIMER) (net stop “Windows SharePoint Services Timer”net start “Windows SharePoint Services Timer” 
(If you wish to change the index location, you can do it then go for step 3)

3. Start office SharePoint Service Search service on index server first. (my observation is stsadm.exe command line tool works better StsAdm.exe -o osearch -action start -role index)

4. Start Office SharePoint Services Search Service on Query Server(s) next. (Command line option StsAdm.exe -o osearch -action start -role query)

5. Wait for couple of minutes.

6. Edit Shared Service Provider (SSP) settings. Select Index Server in drop down list. Provide service credentials and directory path for index location. Click OK

7. Wait for about 10 minutes and check server and search administration page.

Restart requirement

You do not have to restart the servers, need to configure and run full crawl.

Leave a Reply

Your email address will not be published. Required fields are marked *

Enter the Following *